Data Realms Fan Forums
http://forums.datarealms.com/

Weird datafile fail
http://forums.datarealms.com/viewtopic.php?f=1&t=45607
Page 1 of 1

Author:  Tato64 [ Fri Apr 04, 2014 10:10 pm ]
Post subject:  Weird datafile fail

So i was trying to apply Naxete's "Radio backup" from his mod Theatre of Dead (In case you never played with it, its a HDFirearm that spawns a Parachute (Craft) with a soldier (Actor)) to my mod.

Anyways once everything was in place, i add the HDfirearm and Craft to my Index file but when i run the game i get this error message:

---------------------------
RTE Aborted! (x_x)
---------------------------
Failed to load datafile object with following path and name:

NapalmCrew.rte/Craft/Parachute

The last frame has been dumped to 'abortscreen.bmp'

You can copy this message with Ctrl+C
---------------------------

The thing is that the file is there, i can see it, "Parachute.ini" is in "NapalmCrew.rte/Craft", so what's failing?

Any help will be very appreciated, thanks in advance!

Author:  Asklar [ Fri Apr 04, 2014 10:52 pm ]
Post subject:  Re: Weird datafile fail

It's weird. It doesn't seem like the problem is locating the file, or you would get the error saying something like "Index.ini failed to include file at line x" or something like that.

It seems like you are trying to reference an object that doesn't exist in your mod. Remember that the object has to be defined before being referenced anywhere else in the mod. I guess you have the order of the index.ini in such way that the parachute is actually created after being referenced for the first time.

Author:  CaveCricket48 [ Sat Apr 05, 2014 1:21 pm ]
Post subject:  Re: Weird datafile fail

Post the code from the file that calls for Parachute, could give us some more insight.

Author:  Tato64 [ Sun Apr 06, 2014 8:29 pm ]
Post subject:  Re: Weird datafile fail

Hey guys, sorry for taking so long, i'll get home tonight and post the code (The whole .rte maybe?)

Asklar wrote:
Remember that the object has to be defined before being referenced anywhere else in the mod. I guess you have the order of the index.ini in such way that the parachute is actually created after being referenced for the first time.


Created AFTER its referenced?
I figured out it should be created before, so my index is currently in that order...
Guess i'll try to rearrange everything once i get home.

Thanks for everything, will report later!

Author:  Asklar [ Sun Apr 06, 2014 9:42 pm ]
Post subject:  Re: Weird datafile fail

What I mean is that, my guess is that the error is caused because you are defining the parachute after it's referenced. For example, you have a CopyOf = Parachute somewhere before you defined the parachute itself (AddActor = ACraft, rest of code).

But as CaveCricket said, it'd be easier to spot the error with the mod or the file, since we are pretty much guessing blindly :P

Author:  Tato64 [ Mon Apr 07, 2014 12:40 am ]
Post subject:  Re: Weird datafile fail

Here's the complete folder of the craft:
Attachment:
Craft.rar [24.71 KiB]
Downloaded 93 times

(Once again, thanks a lot!)

Author:  CaveCricket48 [ Mon Apr 07, 2014 1:45 am ]
Post subject:  Re: Weird datafile fail

The code is looking for a file named "Parachute.bmp"

You do not have this file with the exact file name.

Author:  Tato64 [ Mon Apr 07, 2014 4:39 am ]
Post subject:  Re: Weird datafile fail

CaveCricket48 wrote:
The code is looking for a file named "Parachute.bmp"

You do not have this file with the exact file name.


Oh god i feel so stupid, how could i miss it?!

For the last time, a million thanks for helping this blind idiot :)

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/