Data Realms Fan Forums

[Solved] "Failed to load datafile" But the files are there
Page 1 of 1

Author:  Tato64 [ Thu Sep 18, 2014 8:27 pm ]
Post subject:  [Solved] "Failed to load datafile" But the files are there

I was working on my faction, creating a new weapon (With the same method i used to create all the other weapons in the faction, which is: Copying the files from a similar weapon, then changing parameters) and when i try to load the game i get this error:

RTE Aborted! (x_x)
Failed to load datafile object with following path and name:


The last frame has been dumped to 'abortscreen.bmp'

You can copy this message with Ctrl+C

The problem is... The file is there, the three files associated to the weapon (FamasMag.bmp, Famas000.bmp and Famas001.bmp) are there, the filepath is not misspelled or not case sensitive.

If i change "FamasMag.bmp" to another file, say, "GalilMag.bmp" it works, but then i get the same error in "Famas000.bmp", which, as i sayed before, is also present in the corresponding folder.

So... What is happening here? What can i do to fix it?

Thanks in advance! :)

UPDATE: Im using the latest version of GIMP and after i edited and saved another file (From a gun which was already working perfectly) it gives me the same error, so it definitely is related. My guess is that this has something to do with the palette.

SOLUTION: Unfortunately i didnt find the problem GIMP is causing, but i found the solution, just open the image in Paint, save it, and close.

Author:  4zK [ Fri Sep 19, 2014 11:49 am ]
Post subject:  Re: [Solved] "Failed to load datafile" But the files are there

The problem is that you're using GIMP.

Author:  Corpsey [ Fri Sep 19, 2014 2:14 pm ]
Post subject:  Re: [Solved] "Failed to load datafile" But the files are there

There's a way to save out of gimp... I've posted somewhere with the solution to do just that.

Corpsey wrote:
...when you're exporting as Windows BMP Image, check "Do not write color space information" under Compatibility Options.


Author:  Tato64 [ Fri Sep 19, 2014 7:15 pm ]
Post subject:  Re: [Solved] "Failed to load datafile" But the files are there

@4zk: I used GIMP to make everything that is present in the mod, it's just that i used an older version. Didnt know the currect one caused this.

@Corpsey: Thanks for reporting the actual cause of the problem! As i said before, this wasnt neccesary in previous versions of GIMP and i didnt know.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group