View unanswered posts | View active topics It is currently Sun Aug 25, 2019 2:46 pm



Reply to topic  [ 3 posts ] 
 Need help on making Nanolyzer-like tool 
Author Message
User avatar

Joined: Sat Nov 23, 2013 4:13 pm
Posts: 24
Location: Graafian follicle
Reply with quote
Post Need help on making Nanolyzer-like tool
I was tring to make a Nanolyzer-like tool that makes concretes instead of goo, but I always end up getting this message:

Code:
Could not match property Error happened in Techion.rte/Devices/Tools/Nanolyzer2.ini at line 14!


And here's the INI file


And oh yeah, some lua script I slightly modified from the original Nanolyzer just to make sure that everything's correct


And the Devices.ini (I put my modded nanolyzer on the bottom of the original one)

I thought that I've done everything correctly but no...
Can anyone help me?


Sun Nov 02, 2014 4:30 am
Profile

Joined: Sun Jul 22, 2012 3:06 pm
Posts: 128
Reply with quote
Post Re: Need help on making Nanolyzer-like tool
Whoa, I tried to figure out what is not working and ended up in a state where I am really questioning how the nanolyzer works at all.

If you create a COMPLETELY PERFECT copy of the nanolyzer, and give it new variables and new pointers to all new files, it doesn't work as effectively as the nanolyzer.

Can anyone explain THAT? @_@


To answer your question though, usually an error like that is from the program trying to collect data that doesn't fit with what it is attempting to collect. Although, we can see here that that's not the case.

After some testing, I think it comes down to the indentation. Make sure you are using the same spacing throughout the document (in this case, I think only TAB spacing works... it's not that difficult to switch from spacebar spacing to TAB spacing - just run a replace function on ' ' (3 spaces) for ' ' (a TAB, which you'll have to copy and paste into the replacement box). In fact, I've had CC run from inputting your code.

It still doesn't explain why a carbon copy of the nanolyzer doesn't work @_@ so, good luck.

Edit: I've found that the 'copy' wasn't working because of this line;
SceneMan:CastStrengthRay(self.MuzzlePos, Vector(aimVec.X, aimVec.Y):RadRotate(i), 1, hitPos, 0, 166, true)

which you can read about how to use here:
viewtopic.php?f=73&t=30651&hilit=CastStrengthRay

Basically, the nanolyzer uses this line to penetrate into terrain by searching for values and ignoring itself. So, to have it 'dig', you have to change '166' to the value of the material you're converting the terrain to based on it's material property (found in Base.rte/Materials.ini). For example, Wet Concrete is 164.

Although, I think another function is that it actually pushes out air (The Tracers) to break the goo material it is replacing the terrain with... So most materials structural integrity is too great to dust away like the nanolyzer goo.


Mon Nov 03, 2014 2:22 pm
Profile
User avatar

Joined: Sat Nov 23, 2013 4:13 pm
Posts: 24
Location: Graafian follicle
Reply with quote
Post Re: Need help on making Nanolyzer-like tool
OK I'll see if it works...
Anyways if it doesn't rly work properly then I'll post more.
EDIT: DAMN! It can't shoot through the terrain! It's just hit the outer parts of a terrain but will NEVER hit the inner parts!
I'm pretty much screwed....


Tue Nov 04, 2014 11:04 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.020s | 15 Queries | GZIP : Off ]