View unanswered posts | View active topics It is currently Fri Aug 18, 2017 11:03 pm



Reply to topic  [ 5 posts ] 
 Sound issues in New Build? 
Author Message
User avatar

Joined: Sun Jan 28, 2007 10:32 pm
Posts: 1608
Location: UK
Reply with quote
Post Sound issues in New Build?
Since the new build was released, it looks like there's sound playback issues with the 40K mod's laser weapons.

The files are 22khz 16bit mono. They worked fine in prior builds.

Anyone got any ideas about what's going on?


Sun Jan 08, 2017 5:29 pm
Profile YIM
DRL Developer
DRL Developer
User avatar

Joined: Thu Jun 11, 2009 2:34 pm
Posts: 959
Reply with quote
Post Re: Sound issues in New Build?
Heya. Those don't play anymore or stutter or smth else? Didn't touch anything related to sound, but who knows, what could cause this.


Mon Jan 16, 2017 2:56 pm
Profile
User avatar

Joined: Sun Jan 28, 2007 10:32 pm
Posts: 1608
Location: UK
Reply with quote
Post Re: Sound issues in New Build?
It seems like they're playing fine on the first shot, but then don't play on any subsequent shots. I'm really not sure exactly what's going on since I haven't changed anything recently either.


Mon Jan 16, 2017 3:41 pm
Profile YIM
User avatar

Joined: Tue Jun 12, 2007 11:52 pm
Posts: 7687
Location: Here
Reply with quote
Post Re: Sound issues in New Build?
Maybe it's not a sound problem, but a problem dealing with the emitters that play them? Are the performance improvements in B32 possibly affecting those?


Tue Jan 17, 2017 1:11 am
Profile
User avatar

Joined: Sun Jan 28, 2007 10:32 pm
Posts: 1608
Location: UK
Reply with quote
Post Re: Sound issues in New Build?
Most of the Las weapons still use the standard FireSound method, so I doubt that's an issue. I've compared it to several other weapons and they seem to be working OK in terms of sound + effects.

What I'm noticing, especially with the Lascannon, is that it can sometimes fail to fire -- and then upon firing another shot, it'll process both shots as intended. The firing sound usually only seems to occur on the first shot of a given magazine or after waiting a short time between shots.

The Brotherhood of Nod seems to be having similar issues with its laser and tiberium flechette weapons (although the GDI's Merlin seems unaffected, oddly).

One constant between all of these is that they have very glow-heavy effects involved.

That said, the Imperium Plasma weapons - which are another set of fairly rapid-fire, glow-heavy weapons - seem completely unaffected and work fine. :???:


Tue Jan 17, 2017 3:50 pm
Profile YIM
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: expakeria, Hilknata


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.022s | 16 Queries | GZIP : Off ]