View unanswered posts | View active topics It is currently Sat Sep 19, 2020 2:47 am



Reply to topic  [ 30 posts ]  Go to page Previous  1, 2
 Screen stays black when I go to full screen 
Author Message

Joined: Fri Jun 01, 2012 10:59 pm
Posts: 103
Reply with quote
Post Re: Screen stays black when I go to full screen
Crabman wrote:
Try running as administrator.
Back in the day, on my old computer,
I manage to get mine working on my windows 7 x86 laptop, with full-screen.
However I find that it's quite slow to sharpaim due to the resolution.

That's all I can suggest. :I

Nope, doesn't work for me. :(


Tue Jun 26, 2012 9:31 am
Profile

Joined: Sun Oct 09, 2011 8:55 pm
Posts: 6
Reply with quote
Post Re: Screen stays black when I go to full screen
sadakat wrote:
Hey y'all, DataRealms has a solution (imperfect, but does the trick):

"Hi, is this a laptop? We recently had an issue with NVidia’s Optimus technology when running cc in fullscreen.. the only thing that seemed to fix it was to in the BIOS of the computer, set the graphics optionss to only use “Discrete graphics”, and not Optimus, which switches between the integrated Intel GPU and Nvidia’s discrete GPU. Only doing the setting in the OS, in Nvidias drivers, trying to force it to use discrete for the CC.exe didn’t seem to help the situation unfortuntately.

This is not an ideal solution, but it does work.. if we find a better solution, we will let you know! If you figure out a fix, let us know :)
- D"



OP here. Decided to try the game out again, and was hoping this issue would be fixed. It isn't. And the problem with the solution you've posted is that many people's BIOS (mine included) does not let you choose to use only the discrete card. I don't know if Data Realms will be working to fix this (or if they even care) but I'd like to know. I imagine this issue affects just about anyone with a laptop with Nvidia Optimus.


Sat Jul 28, 2012 4:27 am
Profile

Joined: Sat Jan 03, 2009 1:12 pm
Posts: 13
Reply with quote
Post Re: Screen stays black when I go to full screen
Jerubbaal wrote:
sadakat wrote:



OP here. Decided to try the game out again, and was hoping this issue would be fixed. It isn't. And the problem with the solution you've posted is that many people's BIOS (mine included) does not let you choose to use only the discrete card. I don't know if Data Realms will be working to fix this (or if they even care) but I'd like to know. I imagine this issue affects just about anyone with a laptop with Nvidia Optimus.


I'm also having problems with a black screen in fullscreen mode with my system. (64bit with optimus)
Havent tried the bios fix. If possible, where in the bios would I find this option?


Sat Jul 28, 2012 10:49 am
Profile

Joined: Sat Jan 03, 2009 1:12 pm
Posts: 13
Reply with quote
Post Re: Screen stays black when I go to full screen
I have found another fix.

When I tried playing on my notebook (windows 7 64bit with nvidia optimus) Screen stayed black on fullscreen.

It works though when I hooked up another moniter and played in dual screen (with the added monitor just displaying desktop)

Hopes this helps


Sat Jul 28, 2012 5:10 pm
Profile

Joined: Sun Oct 09, 2011 8:55 pm
Posts: 6
Reply with quote
Post Re: Screen stays black when I go to full screen
Bump. Just activated this on Steam, still no fix for this :(


Fri Sep 28, 2012 10:31 pm
Profile

Joined: Sat Sep 29, 2012 5:25 am
Posts: 1
Reply with quote
Post Re: Screen stays black when I go to full screen
Here's what I did to get fullscreen working:
1) Run as admin
2) Go to Base.rte
3) Open Settings.ini
4) change Fullscreen = 0 to Fullscreen = 1
5) change NxFullscreen = 2 to NxFullscreen = 1

That's all I did and it runs fullscreen now (1360x760) on my laptop (integrated intel 4 chip) and Windows 8.

I tried messing with the Resolution X/Y but it just whitescreened on me every time so I let it be.


Last edited by piratmonkey on Sat Sep 29, 2012 8:06 am, edited 2 times in total.



Sat Sep 29, 2012 5:29 am
Profile

Joined: Fri Jun 01, 2012 10:59 pm
Posts: 103
Reply with quote
Post Re: Screen stays black when I go to full screen
Jerubbaal wrote:
Bump. Just activated this on Steam, still no fix for this :(

Seems to be working perfectly fine for me. How are you trying to activate it?

Since my laptop's display is 1080p, I just kept it at the default resolution (1920x1080) and it seemed to be set at and pressed ALT+Enter.


Sat Sep 29, 2012 6:48 am
Profile

Joined: Sun Oct 09, 2011 8:55 pm
Posts: 6
Reply with quote
Post Re: Screen stays black when I go to full screen
piratmonkey wrote:
Here's what I did to get fullscreen working:
1) Run as admin
2) Go to Base.rte
3) Open Settings.ini
4) change Fullscreen = 0 to Fullscreen = 1
5) change NxFullscreen = 2 to NxFullscreen = 1

That's all I did and it runs fullscreen now (1360x760) on my laptop (integrated intel 4 chip) and Windows 8.

I tried messing with the Resolution X/Y but it just whitescreened on me every time so I let it be.


See what I bolded, you don't use Optimus, do you?

Anyways, I tried what you suggested, and while I was actually able to see something rendered for once, the display would not refresh at all unless I alt-tabbed, and once I alt-tabbed back in it was stuck on whatever frame it has last rendered while it was minimized.


Sat Sep 29, 2012 1:51 pm
Profile

Joined: Sun Oct 09, 2011 8:55 pm
Posts: 6
Reply with quote
Post Re: Screen stays black when I go to full screen
Malamo999 wrote:
Jerubbaal wrote:
Bump. Just activated this on Steam, still no fix for this :(

Seems to be working perfectly fine for me. How are you trying to activate it?

Since my laptop's display is 1080p, I just kept it at the default resolution (1920x1080) and it seemed to be set at and pressed ALT+Enter.


I entered the key into Steam and downloaded it. In any case, the issue is occurring with both the Steam version and the standalone. Also, does your laptop use Optimus? That's the big issue here.


Sat Sep 29, 2012 1:52 pm
Profile

Joined: Mon Oct 01, 2012 12:16 am
Posts: 3
Reply with quote
Post Re: Screen stays black when I go to full screen
Hey, just bought this game as well and I have the same issue.

Resolution is 1600 x 900 and I have nVidia Optimus. I have tried running as admin, altering Anti Virus, selecting the GPU (discrete graphics) only to run the program and altering the "settings.ini" file but no luck. Still black screen when I go to full-screen.

Anyone have any other ideas?


Mon Oct 01, 2012 12:20 am
Profile

Joined: Mon Oct 01, 2012 12:16 am
Posts: 3
Reply with quote
Post Re: Screen stays black when I go to full screen
Picked up this game today and I'm having the same issue. I've tried:

1) Running as admin
2) Altering the "Settings.ini" file
3) Altering Antivirus permissions
4) Setting my computer to run this via "discrete graphics" by selecting my GPU from the nVidia control panel and yes, my laptop does have Optimus.

No success so far.

Anyone else got any other ideas I could try while we're waiting for a patch.

Best regards,

Rifty.


Mon Oct 01, 2012 12:44 am
Profile

Joined: Tue Oct 02, 2012 12:19 am
Posts: 6
Reply with quote
Post Re: Screen stays black when I go to full screen
I had a similar problem, although it was generally a "pink screen" when I when to full screen mode.
I have a modern NVIDIA video card with updated NVIDIA drivers in Windows 7 64bit, by the way.
And I'm using v1.0 from Steam.

What did work for me was to force the native resolution three ways simultaneously:

1. Force your monitor's native resolution (natural highest guaranteed by the monitor maker + video card maker) in Windows.
This was 1680 x 1050 for me. You set this by using the usual Windows / driver application that came with your video card/OS.

2. Edit the resolution setting in settings.ini in the Base.rte folder of the Cortex Command directory. Make it read the same as your native resolution.

3. Close everything and the start up the CC executable. Try pressing ALT+ENTER. If that fails, go into the options in the CC menu and set that resolution to your native. If that still fails. Shut down the CC, the OS, and the computer. Then reboot and run CC. It should work by that time.

4. If that doesn't do the trick, try repeating the above setting it to a resolution BELOW VGA (640x480), and then after you got it changed to that, then repeat steps 1 through 3.

If that don't work, I don't know what will.


Tue Oct 02, 2012 4:51 am
Profile

Joined: Mon Oct 01, 2012 12:16 am
Posts: 3
Reply with quote
Post Re: Screen stays black when I go to full screen
Hey, I tried what you said and when I start up the program, I get a box saying "current resolution not supported, reverting back to default VGA".

Guess my resolution (1600x900) isn't supported by the game. Shame really, makes it awful difficult to play when the mouse disappears off the screen and you can't see what you're doing :/.


Fri Oct 05, 2012 12:45 am
Profile

Joined: Wed Oct 03, 2012 7:49 am
Posts: 2
Reply with quote
Post Re: Screen stays black when I go to full screen
Seeing as there's no official word on this I don't anticipate a fix any time soon (though it'd be nice) - just thought I'd mention that for me I got around the issue by running the game in a Win XP VM ;) Works fine.


Sun Oct 07, 2012 7:16 am
Profile

Joined: Thu Jul 09, 2009 12:39 am
Posts: 2
Reply with quote
Post Re: Screen stays black when I go to full screen
i was having the same problem.

What i did to fix it is, I kept decrementing the resolutionX and resolutionY vaules untill it worked.
My screen resolution is 1360 x 760 and with the values set to 1300 and 720 it works pretty well.

I also have a laptop and junk o.O

Hope this helps :)


Sun Oct 07, 2012 6:16 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 30 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: Google [Bot]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.020s | 14 Queries | GZIP : Off ]