View unanswered posts | View active topics It is currently Fri Oct 23, 2020 1:12 pm

Reply to topic  [ 3 posts ] 
 Segfault on Linux 
Author Message

Joined: Wed Mar 14, 2012 11:51 pm
Posts: 1
Reply with quote
Post Segfault on Linux
I have build 25, running on Linux Mint Debian Edition, and when I try to run I get this:
bmatt@bmatt-laptop /usr/lib $ /home/bmatt/CortexCommand/CortexCommand
Attempting to start ALSA sound driver
Shutting down Allegro due to signal #11
Segmentation fault

I've seen a few similar errors, but no definitive fixes. What should I do?

Also, will we get build 26 for the HIB version? I've read the 25 doesn't work all that well.

Thu Mar 15, 2012 12:02 am

Joined: Fri May 11, 2012 10:58 pm
Posts: 1
Reply with quote
Post Re: Segfault on Linux
Just would like to report that I'm also having this issue. I'm running Ubuntu 12.04 x64 and proprietary nvidia drivers. For what it's worth, I'm using a dual monitor set up (I'm not sure if that matters, though.) I would love any clue at all as to potential fixes.

I tried doing a backtrace but I'm not very experienced with gdb and it kept insisting that the binary didn't match the core that was dumped (I assure you that it should have.) Here's all it kept reporting:

This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /home/joseph/Games/CortexCommand/CortexCommand.bin...(no debugging symbols found)...done.

warning: core file may not match specified executable file.
[New LWP 16697]

warning: Can't read pathname for load map: Input/output error.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
Core was generated by `./CortexCommand.bin'.
Program terminated with signal 11, Segmentation fault.
#0  0x000000000000ad66 in ?? ()

Fri May 11, 2012 11:09 pm

Joined: Wed Jun 20, 2012 4:09 am
Posts: 1
Reply with quote
Post Re: Segfault on Linux
Same error on my computer. I am running the b25 for Linux on Ubuntu 12.04, 64 bit. I have an Intel GC, GM45 chipset if I remember correctly. I got it to run a year ago on this computer. Not sure what changed. GDB output identical as above minus the part about core file mismatch.

Wed Jun 20, 2012 4:20 am
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: Google [Bot]

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.015s | 16 Queries | GZIP : Off ]