View unanswered posts | View active topics It is currently Wed Sep 26, 2018 4:02 am



Reply to topic  [ 8 posts ] 
 Crashes in 1.0 playing campaing with mods 
Author Message

Joined: Fri Oct 12, 2012 6:44 pm
Posts: 1
Reply with quote
Post Crashes in 1.0 playing campaing with mods
Hello all, i have a really annoying problem while playing the campaing gamemode.
I will whrite exactly what i did:

Player1: me, as Ronin
Player2: AI, Coalition
Player3: AI, Zealots
Player4: AI, Unitec

So, i start the game, capture a zone, build a base, defend it in first days AND THEN i decide to conquer one more location, then... crash!

Ok, i started again, with a new campaing, everything is good except when i try to capture my second place so.. crash again.

Any help?

Thank you.

PS: im not using any mod with vanilla factions or any kind of scenery based mod. Everything is 100% vanilla except unitec guys


Fri Oct 12, 2012 6:55 pm
Profile

Joined: Mon Oct 08, 2012 7:14 pm
Posts: 14
Reply with quote
Post Re: Crashes in 1.0 playing campaing with mods
Did you try without Unitec? (By moving the mod folder out of the Cortex Command directory.)


Sun Oct 14, 2012 5:52 am
Profile

Joined: Fri Jul 15, 2011 6:09 am
Posts: 16
Reply with quote
Post Re: Crashes in 1.0 playing campaing with mods
I'm having the same problem with a custom mod I'm working on. I was playing as Ronin against a bot with my faction on it, and after either 2 or 3 captures, the game crashes randomly.
I made sure to remove all other mods besides my own, so obviously it's causing a problem, but I'm not sure what it is. Everything seems to be in order, and the debug console dump doesn't give me anything to run off of.

My only input into a solution is this: It tends to crash when going into battle on an area I already fought at and captured, so it may have something to do with that. It doesn't really make sense though, because all of the bot's units should already be demolished. Maybe it's something to do with dropping a new ship, but I'm just throwing things out there. Does anybody know what could cause this? I would love to be able to make this faction at least playable.


Thu Nov 01, 2012 12:47 pm
Profile

Joined: Tue Jul 27, 2010 6:29 am
Posts: 38
Reply with quote
Post Re: Crashes in 1.0 playing campaing with mods
Preitty sure this goes in Mod Making, but I too have been having issues with this.


Wed Nov 07, 2012 11:33 am
Profile
User avatar

Joined: Mon Oct 11, 2010 1:15 pm
Posts: 592
Location: Finlandia
Reply with quote
Post Re: Crashes in 1.0 playing campaing with mods
It's the shields. The metagame has some problem with deploying units with HeldDevices.

Try removing all the parts from the Loadout.ini(s) that look something like this:
Code:
   AddCargoItem = HeldDevice
      PresetName = <Mod Folder>.rte/<Shield>


Thu Nov 08, 2012 4:22 pm
Profile

Joined: Fri Jul 15, 2011 6:09 am
Posts: 16
Reply with quote
Post Re: Crashes in 1.0 playing campaing with mods
That didn't seem to do the trick. I suppose offhand weapons count as shields, though. It could be that, but I also have a ton of attachables that I put on actors, which might screw it up as well, but removing them would kind of take away their purpose.


Thu Nov 08, 2012 6:21 pm
Profile
User avatar

Joined: Mon Oct 11, 2010 1:15 pm
Posts: 592
Location: Finlandia
Reply with quote
Post Re: Crashes in 1.0 playing campaing with mods
Offhand weapons are just weapons that the AI thinks are shields, so it holds it in the background with one-handed weapons. Remove them.

I don't understand the attachables, though. I don't think they should matter.


Thu Nov 08, 2012 7:48 pm
Profile

Joined: Fri Jul 15, 2011 6:09 am
Posts: 16
Reply with quote
Post Re: Crashes in 1.0 playing campaing with mods
That seemed to do the trick. Thank you sir. :)


Fri Nov 09, 2012 1:06 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.018s | 13 Queries | GZIP : Off ]