View unanswered posts | View active topics It is currently Thu Sep 19, 2019 7:41 am



Reply to topic  [ 6 posts ] 
 My AIs from my mod from 1.05 dont work well 
Author Message
User avatar

Joined: Sat Jun 23, 2012 2:03 pm
Posts: 340
Location: At home, drinking some tears (probably mine)
Reply with quote
Post My AIs from my mod from 1.05 dont work well
So I heard there was an AI change, but does that affect anything in 1.0 or 1.05 mods? I notice that sometimes my dudes just stand and take bullets without doing anything.


Last edited by AndyChanglee on Mon Apr 21, 2014 4:24 pm, edited 1 time in total.



Sat Apr 19, 2014 10:17 pm
Profile
Data Realms Elite
Data Realms Elite
User avatar

Joined: Fri Jan 07, 2011 8:01 am
Posts: 6211
Location: In your office, earning your salary.
Reply with quote
Post Re: My Actors from my mod for 1.05 dont work well
Your guys should be much smarter than that, are you using the Lua AI defined in Base.rte? That should make them behave correctly.


Sat Apr 19, 2014 11:55 pm
Profile
User avatar

Joined: Sat Jun 23, 2012 2:03 pm
Posts: 340
Location: At home, drinking some tears (probably mine)
Reply with quote
Post Re: My Actors from my mod for 1.05 dont work well
Hmm, might have been a glitch. They work swell now.


Sun Apr 20, 2014 1:04 am
Profile
User avatar

Joined: Sat Jun 23, 2012 2:03 pm
Posts: 340
Location: At home, drinking some tears (probably mine)
Reply with quote
Post Re: My Actors from my mod for 1.05 dont work well
A different question about AI, how do I get them to stop using shotguns at long ranges? Or engage if they do have shotguns?


Sun Apr 20, 2014 2:32 am
Profile
User avatar

Joined: Sun Jan 28, 2007 10:32 pm
Posts: 1609
Location: UK
Reply with quote
Post Re: My Actors from my mod for 1.05 dont work well
You can set AIFireVel and AILifetime on the weapon's Rounds, to tweak how the AI thinks it should use the weapon. For instance, if the shotgun is only really accurate at about half its projectile Lifetime, set AILifetime to half the normal value.


Sun Apr 20, 2014 5:27 am
Profile YIM
User avatar

Joined: Sat Jun 23, 2012 2:03 pm
Posts: 340
Location: At home, drinking some tears (probably mine)
Reply with quote
Post Re: My Actors from my mod for 1.05 dont work well
Ahh, thanks


Sun Apr 20, 2014 4:49 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
[ Time : 0.016s | 14 Queries | GZIP : Off ]